<link>http://people.skolelinux.org/pere/blog/</link>
<atom:link href="http://people.skolelinux.org/pere/blog/index.rss" rel="self" type="application/rss+xml" />
+ <item>
+ <title>New chrpath release 0.16</title>
+ <link>http://people.skolelinux.org/pere/blog/New_chrpath_release_0_16.html</link>
+ <guid isPermaLink="true">http://people.skolelinux.org/pere/blog/New_chrpath_release_0_16.html</guid>
+ <pubDate>Tue, 14 Jan 2014 11:00:00 +0100</pubDate>
+ <description><p><a href="http://www.coverity.com/">Coverity</a> is a nice tool to
+find problems in C, C++ and Java code using static source code
+analysis. It can detect a lot of different problems, and is very
+useful to find memory and locking bugs in the error handling part of
+the source. The company behind it provide
+<a href="https://scan.coverity.com/">check of free software projects as
+a community service</a>, and many hundred free software projects are
+already checked. A few days ago I decided to have a closer look at
+the Coverity system, and discovered that the
+<a href="http://www.gnu.org/software/gnash/">gnash</a> and
+<a href="http://sourceforge.net/projects/ipmitool/">ipmitool</a>
+projects I am involved with was already registered. But these are
+fairly big, and I would also like to have a small and easy project to
+check, and decided to <ahref="scan.coverity.com/projects/1179">request
+checking of the chrpath project</a>. It was
+added to the checker and discovered seven potential defects. Six of
+these were real, mostly resource "leak" when the program detected an
+error. Nothing serious, as the resources would be released a fraction
+of a second later when the program exited because of the error, but it
+is nice to do it right in case the source of the program some time in
+the future end up in a library. Having fixed all defects and added
+<a href="https://lists.alioth.debian.org/mailman/listinfo/chrpath-devel">a
+mailing list for the chrpath developers</a>, I decided it was time to
+publish a new release. These are the release notes:</p>
+
+<p>New in 0.16 released 2014-01-14:</p>
+
+<ul>
+
+ <li>Fixed all minor bugs discovered by Coverity.</li>
+ <li>Updated config.sub and config.guess from the GNU project.</li>
+ <li>Mention new project mailing list in the documentation.</li>
+
+</ul>
+
+<p>You can
+<a href="https://alioth.debian.org/frs/?group_id=31052">download the
+new version 0.16 from alioth</a>. Please let us know via the Alioth
+project if something is wrong with the new release. The test suite
+did not discover any old errors, so if you find a new one, please also
+include a test suite check.</p>
+</description>
+ </item>
+
<item>
<title>Debian Edu interview: Dominik George</title>
<link>http://people.skolelinux.org/pere/blog/Debian_Edu_interview__Dominik_George.html</link>
</description>
</item>
- <item>
- <title>Running TP-Link MR3040 as a batman-adv mesh node using openwrt</title>
- <link>http://people.skolelinux.org/pere/blog/Running_TP_Link_MR3040_as_a_batman_adv_mesh_node_using_openwrt.html</link>
- <guid isPermaLink="true">http://people.skolelinux.org/pere/blog/Running_TP_Link_MR3040_as_a_batman_adv_mesh_node_using_openwrt.html</guid>
- <pubDate>Sun, 10 Nov 2013 23:00:00 +0100</pubDate>
- <description><p>Continuing my research into mesh networking, I was recommended to
-use TP-Link 3040 and 3600 access points as mesh nodes, and the pair I
-bought arrived on Friday. Here are my notes on how to set up the
-MR3040 as a mesh node using
-<a href="http://www.openwrt.org/">OpenWrt</a>.</p>
-
-<p>I started by following the instructions on the OpenWRT wiki for
-<a href="http://wiki.openwrt.org/toh/tp-link/tl-mr3040">TL-MR3040</a>,
-and downloaded
-<a href="http://downloads.openwrt.org/snapshots/trunk/ar71xx/openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-factory.bin">the
-recommended firmware image</a>
-(openwrt-ar71xx-generic-tl-mr3040-v2-squashfs-factory.bin) and
-uploaded it into the original web interface. The flashing went fine,
-and the machine was available via telnet on the ethernet port. After
-logging in and setting the root password, ssh was available and I
-could start to set it up as a batman-adv mesh node.</p>
-
-<p>I started off by reading the instructions from
-<a href="http://wirelessafrica.meraka.org.za/wiki/index.php?title=Antoine's_Research">Wireless
-Africa</a>, which had quite a lot of useful information, but
-eventually I followed the recipe from the Open Mesh wiki for
-<a href="http://www.open-mesh.org/projects/batman-adv/wiki/Batman-adv-openwrt-config">using
-batman-adv on OpenWrt</a>. A small snag was the fact that the
-<tt>opkg install kmod-batman-adv</tt> command did not work as it
-should. The batman-adv kernel module would fail to load because its
-dependency crc16 was not already loaded. I
-<a href="https://dev.openwrt.org/ticket/14452">reported the bug</a> to
-the openwrt project and hope it will be fixed soon. But the problem
-only seem to affect initial testing of batman-adv, as configuration
-seem to work when booting from scratch.</p>
-
-<p>The setup is done using files in /etc/config/. I did not bridge
-the Ethernet and mesh interfaces this time, to be able to hook up the
-box on my local network and log into it for configuration updates.
-The following files were changed and look like this after modifying
-them:</p>
-
-<p><tt>/etc/config/network</tt></p>
-
-<pre>
-
-config interface 'loopback'
- option ifname 'lo'
- option proto 'static'
- option ipaddr '127.0.0.1'
- option netmask '255.0.0.0'
-
-config globals 'globals'
- option ula_prefix 'fdbf:4c12:3fed::/48'
-
-config interface 'lan'
- option ifname 'eth0'
- option type 'bridge'
- option proto 'dhcp'
- option ipaddr '192.168.1.1'
- option netmask '255.255.255.0'
- option hostname 'tl-mr3040'
- option ip6assign '60'
-
-config interface 'mesh'
- option ifname 'adhoc0'
- option mtu '1528'
- option proto 'batadv'
- option mesh 'bat0'
-</pre>
-
-<p><tt>/etc/config/wireless</tt></p>
-<pre>
-
-config wifi-device 'radio0'
- option type 'mac80211'
- option channel '11'
- option hwmode '11ng'
- option path 'platform/ar933x_wmac'
- option htmode 'HT20'
- list ht_capab 'SHORT-GI-20'
- list ht_capab 'SHORT-GI-40'
- list ht_capab 'RX-STBC1'
- list ht_capab 'DSSS_CCK-40'
- option disabled '0'
-
-config wifi-iface 'wmesh'
- option device 'radio0'
- option ifname 'adhoc0'
- option network 'mesh'
- option encryption 'none'
- option mode 'adhoc'
- option bssid '02:BA:00:00:00:01'
- option ssid 'meshfx@hackeriet'
-</pre>
-<p><tt>/etc/config/batman-adv</tt></p>
-<pre>
-
-config 'mesh' 'bat0'
- option interfaces 'adhoc0'
- option 'aggregated_ogms'
- option 'ap_isolation'
- option 'bonding'
- option 'fragmentation'
- option 'gw_bandwidth'
- option 'gw_mode'
- option 'gw_sel_class'
- option 'log_level'
- option 'orig_interval'
- option 'vis_mode'
- option 'bridge_loop_avoidance'
- option 'distributed_arp_table'
- option 'network_coding'
- option 'hop_penalty'
-
-# yet another batX instance
-# config 'mesh' 'bat5'
-# option 'interfaces' 'second_mesh'
-</pre>
-
-<p>The mesh node is now operational. I have yet to test its range,
-but I hope it is good. I have not yet tested the TP-Link 3600 box
-still wrapped up in plastic.</p>
-</description>
- </item>
-
</channel>
</rss>